馬達的問題

請問各位高手有用過伺服馬達作控制的

我現在把伺服驅動器的CN I/F接頭那邊接線接好了

但是我沒有給他任何指令就開始動了

可能的原因是什麼呢? (用P命令)

部分伺服馬達在出廠時都是預設在速度控制模式~~ 若已經設定模式後還會自行運動時請確認是否有雜訊或干擾。

[QUOTE=Axel]

部分伺服馬達在出廠時都是預設在速度控制模式~~ 若已經設定模式後還會自行運動時請確認是否有雜訊或干擾。

[/QUOTE]

也就是說調一調之後就會好了嗎? 用哪種接線 就用那種模式?

那調好還會這樣的雜訊或干擾是怎麼產生的   接線沒接好嗎?

之前用LABVIEW (馬達卡) 來接伺服馬達驅動器 跟 現在用PLC來接伺服馬達驅動器 

都會是這樣沒給指令就在那邊動 (都是用P命令)

為什麼速度模式會自行轉動阿?

(我用的是國際牌AC伺服馬達驅動器)

PANASONIC 的 AC SERVO 有速度控制、位置控制及轉距控制模式,在出廠時會預設成速度控制模式。

如果要以脈衝控制時須設成 "位置控制模式",大大您可以改變伺服控制器的 Pr02值為 0 (0:位置、1:速度、2:轉距、3:位置+速度、4:位置+轉距、5:速度+轉距)

Pr02 值若為 0~2 則為單純控制模式,3~5為複合模式並以 CN I/F 接點 32(C MODE)進行模式選擇

Pr02 = 3、CN I/F 接點 32 斷路=位置控制模式、CN I/F 接點 32 接地=速度控制模式

Pr02 = 4、CN I/F 接點 32 斷路=位置控制模式、CN I/F 接點 32 接地=轉距控制模式

Pr02 = 5、CN I/F 接點 32 斷路=速度控制模式、CN I/F 接點 32 接地=轉距控制模式

以上~~ 希望能解決大大您的困擾。

之前沒調PR的時候,都會有馬達啟動的聲音,然後自己在那邊轉動

現在則是....馬達卡7342接UMI7764然後接驅動器 . 調了PR之後  馬達就沒有運轉的聲音了....

會不會有可能因為錯誤操作讓馬達燒掉了.....?  還是接線沒接好???

如果 PR02 設定成 0 的時候 SERVO便會進入位置模式,不會有任何雜音。

大大可以用手扭動馬達軸心,看看是否有積磁,正常的話馬達應該會有逆向的動力回應,

此時伺服驅動器上的數字亦會跳動,接著便可用 NI-MOTION 所附的 UTILITY 進行試運轉。

UMI-7764 接線部分需提供 DC+5V & Ground PLS+ PLS- DIR+ DIR- 接線也請確認一下。

小弟玩過 7344 & 7324 都還滿容易上手的,唯有 Function 呼叫部份令人頭痛

PS# 玩 CVI 好辛苦..........

現在伺服馬達因該是進入位置控制模式了!!   也如同大大你講的一樣去轉動他 顯示器上面的數字會有跳動!!

因此有可能是接線的問題  , 所以我來講講我的接法!! http://photo.xuite.net/a921020107/953182 

外部電源是用PLC來接  (驅動器部分)

35 37 39 11 40 12 接在一起之後 35去連VDC12~24V的正極   ,  7也去連正極

33 30 29 27 28 32 31 9 8 34 36 38 10 41 接在一起之後   ,   41去連VDC的負極

44.45不知道什麼功用,不接      50也沒用     

3~24那邊先問一個問題     看書本,那個畫圓圈的好像是叫雙絞線(對絞線)有一定要用那種線嗎?

我是先把3.4連起來 然後兩個去接13的接地 , 把3牽出來(如圖 . 不太好理解的圖)     5.6也是一樣,然後5的牽出來

21.22連起來 然後兩個去接25的接地  , 把21牽出來       48.49也是一樣,然後48牽出來     23.24也相同,然後23牽出來

19沒用 , 14~42那邊也是沒用

UMI-7764部分  

+5V那個地方是去把VDC12~24的正極拿來接

Digital Ground我是用VDC12~24負極拿來接--->這我知道我錯....

21.48.23 我各是接在 Analog Output . Analog Output Ground . Inhibit Output 上面

3.5 各是接在 Step(cw)  Dir (ccw)

總覺得錯很大 , 希望大大你再次指教....謝謝

92102010738922.6573726852

刪除

92102010738922.646875

[QUOTE=921020107][QUOTE=Axel]

如果 PR02 設定成 0 的時候 SERVO便會進入位置模式,不會有任何雜音。

大大可以用手扭動馬達軸心,看看是否有積磁,正常的話馬達應該會有逆向的動力回應,

此時伺服驅動器上的數字亦會跳動,[/QUOTE]

控制模式進入位置模式了!!  如圖(控制方式顯示)

然後大大說的用手扭動馬達軸心,  伺服驅動器上的數字亦會跳動..... 

Pr01 LED顯示狀況

一開機顯示是速度模式的話 , 會像大大說的驅動器的數字會挑動,

不過改成位置模式就不會跳動是怎麼樣 , 這樣是正確的嗎?

如圖(開機顯示 轉動有反應!!) (換成這種開機顯示 , 轉動無反應!!)

[/QUOTE] 92102010738922.6481712963

@@a 大大您的接法真得改一下了~~ 我說一下最簡單的接線方式

AC SERVO 輸入部分:

7.COM+ 接 DC12-24V,29.SERVO-ON 只要引 DC 的接地進去伺服馬達便會激磁,可以用 PLC 來控制。

31. ALARM-CLEAR 接地時可以重置馬達故障,如以PLC控制則可免去關閉電源來重置驅動器

8,9. 可讓您接上光電開關或極限開關,避免撞機。(注意接點為 NC 點,OPEN 則啟動)

AC SERVO 輸出部分:

34,35 當驅動器進入待命模式時輸出(自啟動電源到待命為止呈現 OFF)

36,37 驅動器發生異常時該接點作動,便於您進行監控

38,39 伺服馬達停止時皆會出現補償運動,無一定位置,此時可由驅動器中設定定位範圍,如馬達到達此範圍時驅動器便會將此點輸出。

AC SERVO 位置控制部分:

PULS1(+),PULS2(-) 相當於 CW+,CW-

SIGN1(+),SIGN(-) 相當於 CCW+,CCW-

如果要接在 7764 上的話,請將 PULS1 和 SIGN1 並接,然後接到 7764 的 +5V(OUTPUT)。 PULS2 接到7764的STEP(CW),SIGN2 接到 7764 的 DIR(CCW)。

ENCODER 的部份

OA+ 接 Encoder Phase A, OA- 接 Encoder Phase A(BAR)

OB+ 接 Encoder Phase B, OB- 接 Encoder Phase B(BAR)

OZ+ 接 Encoder Index, OZ- 接 Encoder Index(BAR)

7764 的中間靠近出線口的地方有個小端子座接上 +5V 及 地線,之後就可以工作了

 

PS## AC-SERVO 的 SERVO-ON 一定要送電否則馬達不會激磁唷,至於 PR02 設定請按驅動器 MODE 鍵幾次當畫面出現 PA _  00 時再以上下鍵選至 PA 02 然後壓 SET 鍵進去設定為 0,完成後再壓SET 回到 PA 02。如果要將參數存檔請繼續壓 MODE 直到畫面出現 EE_SET,然後押SET (畫面改為 EEP),此時壓向上鍵不放,直到畫面全度出現負號並閃爍就存入囉,存入後不會因為關閉電源而改變參數。

祝大大成功唷~~

我現在是把7COM+ 接到 DC12~24V那邊   29.31接到"41COM-"也就是DC12~24V負極那邊! 8.9沒接

34連35然後35連到7   36連37然後37連到7   38連39然後39連到7

至於7764    請將 PULS1 和 SIGN1 並接  , 是不是把 3 跟 5 連在一起 , 然後我把3拿去連+5V(OUTPUT)....

其他因該是沒問題  這樣接線有錯嗎?

不過還是不鳥我@@? 

用MAX測試的時候   伺服模式 跟 閉迴路模式都試過了

MOTION小幫手也有用過   還是NO OK

有空勞煩幫忙一下小弟我, 真的感激不進!!

因為在找

是不是其他地方出問題 

我的接頭是用這種的 http://tw.f5.page.bid.yahoo.com/tw/auction/e14446553(借圖)

而且經過多次焊接 , 不知道有沒有濫掉

 

 

92102010738923.7056944444

http://photo.xuite.net/a921020107/953182   圖UMI7764@_@

那個五的地方,也就是大大所說

7764 的中間靠近出線口的地方有個小端子座接上 +5V 及 地線 , 是接外部電源嗎?

今天拿電源供應器拿過來是....... 結果還是不行 ,

還把7764接線盒 , 不知道有沒有搞壞....  因為之前先調4.X多,之後想說改成5好了

所以在調伏特數的時候 , 因為沒有增加 , 然後不小心把安培數轉太多.....    朋友在那邊說 好像有聞到一股臭味

拆掉之後聞  好像也有味道.....  還是心裡有鬼?  他是判死刑了嗎?

但是總覺得還是沒有壞掉耶...............

假如壞掉=.=....馬達卡會跟者壞掉嗎=.=||............

92102010738923.8979282407

 

 

![](upload://aeCWpSDBa373juoGt1M5ekL7kDP.jpeg)

 

給您一個最簡單的接線圖.... 加油囉

zuo  de  hao 

[QUOTE=Axel]

 

 

![](upload://aeCWpSDBa373juoGt1M5ekL7kDP.jpeg)

 

給您一個最簡單的接線圖.... 加油囉

[/QUOTE]

那 LABVIEW 中的MAX設定 , 要怎麼設定呢?  

這邊到是讓我極度苦惱